Основы. Бухгатерский запрос, атрибуты и методы результата запроса

При обходе группировок результата запроса возможно обращение к следующим атрибутам и методам:


Атрибут Описание
Счет Текущий счет, выбранный функцией ПолучитьСчет
КорСчет Текущий корр. счет, выбранный функцией ПолучитьКорСчет
Валюта Текущая валюта, выбранная функцией ПолучитьВалюту
НачДата
КонДата
Начальная и конечная дата текущего периода, выбранного функцией ПолучитьПериод
Операция Атрибут позволяет обращаться к текущей операции, если запрос получен с детализацией итогов по периоду «Операция» и «Проводка».



Метод Описание
Субконто
КорСубконто

ПредставлениеСубконто
ПредставлениеКорСубконто
Синтаксис
Субконто(<Номер> | <ВидСубконто>)
КорСубконто(<Номер> | <ВидСубконто>)
Пример:
БухИтоги.ИспользоватьСубконто(ВидыСубконто.Товары, , 1);

БухИтоги.ВыполнитьЗапрос(ДатаНач, ДатаКон);

БухИтоги.ВыбратьСубконто();

Пока БухИтоги.ПолучитьСубконто() = 1 цикл

.........
Сообщить(БухИтоги.Субконто());

КонецЦикла;
ЭтоГруппа Для тех субконто, которые выбираются из иерархических справочников метод возвращает 1, если текущее значение вляется группой справочника.
СНД
СНК
СКД
СКК
ДО
КО
СНД — дебетовое сальдо на начало периода;

СКД — дебетовое сальдо на конец периода;

СНК — кредитовое сальдо на начало периода;
СКК — кредитовое сальдо на конец периода;

ДО — дебетовый оборот за период;

КО — кредитовый оборот за период.
Синтаксис (у всех одинаковый): СНД(<ТипСуммы>)
Параметр <ТипСуммы> может принимать следующие
значения:
  • 1 (“С”) – сумма (по умолчанию)
  • 2 (“В”) – валютная сумма
  • 3 (“К”) – количество

СНДРС
СКДРС
СНКРС
СККРС
СНДРС — дебетовое развернутое сальдо на начало периода;

СКДРС — дебетовое развернутое сальдо на конец периода;

СНКРС — кредитовое развернутое сальдо на начало периода;

СККРС — кредитовое развернутое сальдо на конец периода;
КорДО
КорКО
Возвращает дебетовый или кредитовый оборот между корреспондирующими счетами или субконто.
ВыбранаПоДт
ВыбранаПоКт
Эти функции возвращают 1, если выбран итог по дебету / кредиту.

| опубликовано: 26 Март 2010, 17:30

Основы. Бухгатерский запрос, обработка результатов запроса (обход группировок)

Методы обхода группировок результата запроса приведены ниже:

























Методы Описание
ВыбратьСчета
ПолучитьСчет
Синтаксис: ВыбратьСчета(<ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>)

















Параметр Описание
<ФлагВсе> Необязательный параметр.
  • 0 — отбирать те счета, которые имели итоги на этом уровне обхода итогов запроса (по умолчанию);
  • 1 — включить в выборку все счета, которые имели итоги в данном запросе;
  • -1, -2 … — включить в выборку счета, которые имели итоги в группировке n-го вышестоящего уровня.

<ФлагДК> Необязательный параметр.
  • 1 — включать в выборку счета только с дебетовыми оборотами;
  • 2 — включать в выборку счета только с кредитовыми оборотами.
  • 0 — включать в выборку счета вне зависимости от дебетовых/кредитовых оборотов (по умолчанию).

<Номер> Необязательный параметр. Положительное целое число — номер выборки. Если параметр не указан, выборке присваивается номер 0. Выборке, открываемой методом ВыбратьСчета, может быть присвоен номер — положительное целое число. Номер — это «метка» выборки. Номер может использоваться для обращения к результатам выборки при помощи метода ПолучитьСчет. Использование этой метки необходимо, если требуется получить две группировки по счету.
<РазвСальдо> Необязательный параметр. Признак необходимости рассчитывать развернутое сальдо по субконто. Используется только если в запросе участвуют субконто.
  • 1 — рассчитывать развернутое сальдо.
  • 0 — не рассчитывать развернутое сальдо (по умолчанию);


Синтаксис: ПолучитьСчет(<Номер>, <Счет>)











Параметр Описание
<Номер> Необязательный параметр. Положительное целое число — номер выборки. Если раньше было открыто несколько выборок по счету.
<Счет> Необязательный параметр. Конкретное значение счета, которое нужно получить из выборки.

Пример.
БухИтоги.Запрос(Дата1, Дата2);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 Цикл
Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();
КонецЦикла;
ВыбратьКорСчета
ПолучитьКорСчет
Синтаксис:
ВыбратьКорСчета(<ФлагВсе>,<ФлагДК>,<Номер>)
ПолучитьКорСчет(<Номер>, <Счет>)
Пример:

БухИтоги.Запрос(Дата1, Дата2);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 Цикл

БухИтоги.ВыбратьКорСчета();

Пока БухИтоги.ПолучитьКорСчет() = 1 Цикл

Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();

КонецЦикла;

КонецЦикла;

ВыбратьВалюты
ПолучитьВалюту
Синтаксис:
ВыбратьВалюты(<ФлагВсе>, <ФлагДК>, <Номер> , <РазвСальдо>, <Сортировка>)
ПолучитьВалюту(<Номер>, <Валюта>)

Пример:

БухИтоги.Запрос(Дата1, Дата2);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 цикл

БухИтоги.ВыбратьВалюты();

Пока БухИтоги.ПолучитьВалюту() = 1 цикл

ДебВ = БухИтоги.ДО(2);

КредВ = БухИтоги.КО(2);
КонецЦикла;

КонецЦикла;
ВыбратьПериоды
ПолучитьПериод
Синтаксис:
ВыбратьПериоды(<ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>)
ПолучитьПериод(<Номер>, <ДатаНачалаПериода>)

Пример:

БухИтоги.ВыполнитьЗапрос(Дата1, Дата2, , , , , “Месяц”);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 цикл

БухИтоги.ВыбратьПериоды();

Пока БухИтоги.ПолучитьПериод() = 1 цикл

Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();

КонецЦикла;

КонецЦикла;
ВыбратьСубконто
ПолучитьСубконто
Синтаксис:
ВыбратьСубконто(<Индекс>, <ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>, <Сортировка>, <ПорядокОбхода>)
ПолучитьСубконто(<Индекс>, <Номер>, <Субконто>)

Пример:

БухИтоги.ИспользоватьСубконто(ВидыСубконто.Материалы, , 1);

БухИтоги.ИспользоватьСубконто(ВидыСубконто.Склады, , 1);

БухИтоги.ВыполнитьЗапрос(ДатаНач, ДатаКон, “10”);

БухИтоги.ВыбратьСубконто(1);

Пока БухИтоги.ПолучитьСубконто(1) = 1 цикл

БухИтоги.ВыбратьСубконто(2);

Пока БухИтоги.ПолучитьСубконто(2) = 1 цикл

Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();

КонецЦикла;

КонецЦикла;
ВыбратьКорСубконто
ПолучитьКорСубконто
Синтаксис:
ВыбратьКорСубконто(<Индекс>, <ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>, <Сортировка>, <ПорядокОбхода>)
ПолучитьКорСубконто(<Индекс>, <Номер>, <Субконто>)

БухИтоги.ИспользоватьСубконто(ВидыСубконто.Товары, , 1);

БухИтоги.ИспользоватьКорСубконто(ВидыСубконто.Клиенты, , 1);

БухИтоги.ВыполнитьЗапрос(ДатаНач, ДатаКон);

БухИтоги.ВыбратьСубконто();

Пока БухИтоги.ПолучитьСубконто() = 1 цикл

БухИтоги.ВыбратьКорСубконто();

Пока БухИтоги.ПолучитьКорСубконто() =1 цикл

Деб = БухИтоги.КорДО();

Кред = БухИтоги.КорКО();

КонецЦикла;

КонецЦикла;

| опубликовано: 12 Март 2010, 17:05

Основы. Бухгатерский запрос, метод Опции

Синтаксис:Опции(<ВключатьЗабалансовыеСуммы>, <ВключатьОборотныеСубконтоСуммы>)
Метод Опции должен вызываться до выполнения метода ВыполнитьЗапрос. Он устанавливает режимы включения в итоги сумм по забалансовым счетам и оборотным субконто. Если метод не вызвался, суммы по забалансовым счетам и оборотным суб­конто не включаются в запрос.
Если параметр равен 1, то эти суммы включаются в запрос, если 0, то не включаются.

| опубликовано: 5 Март 2010, 14:05


<--- Предыдущая страница